Returns the angular increment along a bar or hook bend to which the RebarConstraint is attached.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The angular increment relative to the reference bar edge.Remarks
Only applies to RebarConstraints with TargetRebarConstraintType BarBend or HookBend. For HookBends, values can be 0, 1, 2, 3 or 4, representing angular locations of 0, 45, 90, 135, and 180 degrees around the hook, starting at the 'base' of the hook (or end of the bar without hook). For interior BarBends, values can 0 or 1, where 0 means at the intersection of the bar bend and the edge specified by getTargetRebarEdgeNumber, and 1 means the mid-point of the bend arc. Rebar must be Shape Driven Rebar element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.' -or- The RebarTargetConstraintType is not 'HookBend' or 'BarBend'. -or- Constrained rebar is a free form rebar element. |