Checks if the id can be applied as the scheme id of specified category to this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryId
- Type: Autodesk.Revit.DB ElementId
The id of category.
- schemeId
- Type: Autodesk.Revit.DB ElementId
The id of color fill scheme.
Return Value
True if the id can be applied as the scheme id of specified category in this view, false otherwise.Remarks
The input scheme id could be InvalidElementId to clear the scheme for the specified category.
Some examples of returnning false:
- The id is not a color fill scheme id.
- The specified category is not supported by this view.
- The category of scheme is not the same as the specified category.
- The view is area plan but the scheme category is not OST_Areas, or their [!:Autodesk::Revit::DB::AreaScheme] are not the same.
- Etc.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |