IsValidValue Method (IList(Double))


Checks that the value is a valid value for this property.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018.1

Syntax

C#
public bool IsValidValue(
	IList<double> value
)
Visual Basic
Public Function IsValidValue ( _
	value As IList(Of Double) _
) As Boolean
Visual C++
public:
bool IsValidValue(
	IList<double>^ value
)

Parameters

value
Type: System.Collections.Generic IList Double
The value to be checked.

Return Value

True if the value is valid for the property.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null
Autodesk.Revit.Exceptions InvalidOperationException Cannot check validity for a property not being edited in AppearanceAssetEditScope.

See Also