Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- viewTemplate
- Type: Autodesk.Revit.DB View
The view template which apply to the view.
- useCurrentPrintSettings
- Type: System Boolean
If true, print the view with the print setting of the current active document; otherwise with the view's document's print setting.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the view cannot be printed. |