TypeId Property


Specifies the ElementId of the label type. The default value is InvalidElementId. In this case, the default type id for alignment station labels in the document is used.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021.1

Syntax

C#
public ElementId TypeId { get; set; }
Visual Basic
Public Property TypeId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ TypeId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Remarks

Valid types can be found using IsValidType(Element) .

See Also