ElectricalDemandFactorDefinition Class


The ElectricalDemandFactorDef class represents a serialized version of an instance of demand factor definition. It has a name, rule type, and values for the rules that are serialized.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public class ElectricalDemandFactorDefinition : Element
Visual Basic
Public Class ElectricalDemandFactorDefinition _
	Inherits Element
Visual C++
public ref class ElectricalDemandFactorDefinition : public Element

Inheritance Hierarchy

System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Electrical ElectricalDemandFactorDefinition

See Also