SetTessellationSettings Method


Sets all the tessellation parameters to its predefined values for the given resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2021.1

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use 'setTessellationSettings(ExportResolution::Enum)' method instead.")]
public void SetTessellationSettings(
	STLExportResolution resolutionType
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use 'setTessellationSettings(ExportResolution::Enum)' method instead.")> _
Public Sub SetTessellationSettings ( _
	resolutionType As STLExportResolution _
)
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use 'setTessellationSettings(ExportResolution::Enum)' method instead.")]
public:
void SetTessellationSettings(
	STLExportResolution resolutionType
)

Parameters

resolutionType
Type: Autodesk.Revit.DB STLExportResolution
Type of STL exporting resolution.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also