SetGeometryCurve Method


Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015

Syntax

C#
public void SetGeometryCurve(
	Curve curve,
	bool overrideJoins
)
Visual Basic
Public Sub SetGeometryCurve ( _
	curve As Curve, _
	overrideJoins As Boolean _
)
Visual C++
public:
void SetGeometryCurve(
	Curve^ curve, 
	bool overrideJoins
)

Parameters

curve
Type: Autodesk.Revit.DB Curve
The new curve.
overrideJoins
Type: System Boolean
An option to specify whether or not existing joins will affect setting the geometry of the CurveElement. Setting this parameter to false is essentially the same as directly setting the GeometryCurve property.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown if the argument is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions ArgumentException Thrown if the input curve is of a type different from the current. -- or -- Thrown if the input curve is bound and the current is not or vice versa. -- or -- Thrown if the input curve is helical. -- or -- Thrown if the input curve lies outside of the SketchPlane of the current curve and the CurveElement is not CurveByPoints.

See Also