GetEquivalentReferenceFromMassOrLevel Method


Returns a Reference to a face of a MassEnergyAnalyticalModel element or an element Reference to a MassLevelData element. This Reference represents what the MassZone face was "cut from" when making the MassZone for the level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012

Syntax

C#
public Reference GetEquivalentReferenceFromMassOrLevel(
	Reference referenceToZoneFace
)
Visual Basic
Public Function GetEquivalentReferenceFromMassOrLevel ( _
	referenceToZoneFace As Reference _
) As Reference
Visual C++
public:
Reference^ GetEquivalentReferenceFromMassOrLevel(
	Reference^ referenceToZoneFace
)

Parameters

referenceToZoneFace
Type: Autodesk.Revit.DB Reference
Reference to a face of the zone to get an equivalent reference for.

Return Value

Reference to MassEnergyAnalyticalModel or MassLevelData. Should only be a null reference ( Nothing in Visual Basic) if there is an error in the MassEnergyAnalyticalModel data or the input is not a

Remarks

If the Reference is to a MassLevelData element, it means that the MassEnergyAnalyticalModel element did not have an exterior face for this MassZone face. For this case, the MassZone face was created as the cross-section of the MassEnergyAnalyticalModel geometry where it was intersected by the level of the MassLevelData.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The input Reference is not a face Reference of this MassZone.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also