Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- outline
- Type: Autodesk.Revit.DB Outline
The Outline used to find elements with a bounding box that are contained by it.
- tolerance
- Type: System Double
The tolerance value to use instead of zero. See the tolerance property for details.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |