GetAllSupports Method


Retrieves all supports hosted by the stair's run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013

Syntax

C#
public IList<ElementId> GetAllSupports()
Visual Basic
Public Function GetAllSupports As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetAllSupports()

Return Value

All supports hosted by the stair's run.

Remarks

The supports consist of left, right, and middle supports of the stair's run.

See Also