CategoryIdForConceptualSurfaceType Property


Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public ElementId CategoryIdForConceptualSurfaceType { get; }
Visual Basic
Public ReadOnly Property CategoryIdForConceptualSurfaceType As ElementId
	Get
Visual C++
public:
property ElementId^ CategoryIdForConceptualSurfaceType {
	ElementId^ get ();
}

Remarks

This value is determined by starting with the subcategory property and adjusting it according to properties such as "isSlab" or "isUnderground".

See Also