MoveBarInSet Method


This method applies the transformation matrix to the rebar bar at the desired position in the rebar set. If the bar was already moved, the method will concatenate the transformation matrix with the existing movement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public void MoveBarInSet(
	int barPositionIndex,
	Transform moveTransform
)
Visual Basic
Public Sub MoveBarInSet ( _
	barPositionIndex As Integer, _
	moveTransform As Transform _
)
Visual C++
public:
void MoveBarInSet(
	int barPositionIndex, 
	Transform^ moveTransform
)

Parameters

barPositionIndex
Type: System Int32
The bar index of the rebar to apply the transformation.
moveTransform
Type: Autodesk.Revit.DB Transform
The transformation matrix to apply to the specified rebar bar.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null
Autodesk.Revit.Exceptions ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ].
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions InapplicableDataException For this RebarInSystem element individual bars can't be moved, excluded or included.

See Also