DemandFactorId Property


The demand factor definition this load classification element uses.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011

Syntax

C#
public ElementId DemandFactorId { get; set; }
Visual Basic
Public Property DemandFactorId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ DemandFactorId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The element id elemId is not a valid ElectricalDemandFactorDefinition element.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also