Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
Return values from inquiries about the worksharing status of elements or worksets rely on local caching of information from the central model so it is possible that the information is out of date. Because of this, the return value is suitable for reporting to an interactive user (e.g. via a mechanism similar to Worksharing display mode), but cannot be considered a reliable indication of whether the element can be immediately edited by the application. To make an immediate attempt to edit elements, use [!:CheckoutElements()] and check the return status, then confirm if the elements are up to date.
In addition, information about the current user may not be reliable while Revit is in the middle of an editing transaction. For example, if you move an unowned wall from an unowned workset to a workset you own, then before you explicitly or Revit automatically checks out the wall for you, GetCheckoutStatus() might erroneously tell you CheckoutStatus.OwnedByCurrentUser because although the official (as seen in central and by other users) owner is no one, locally it looks like you already own it since it belongs to a workset you own.
For operations that interact with central (as opposed to use only cached values), Revit might opportunistically refresh some editing permissions or check the status of editing requests.
Some useful definitions to keep in mind follow:
- The owner of a workset: the user who has the Workset checked out; this could be nobody (the empty string).
- The borrower of an element: the user who has explicitly checked out ("borrowed") the Element; this could be nobody.
- The owner of an element: If element is borrowed (i.e. explicitly checked out), then the element's owner is the borrower, otherwise it is the owner or the workset containing the element.
Examples

public void GetElementWorksharingInfo(Document doc, Element elem)
{
String message = String.Empty;
message += "Element Id: " + elem.Id;
// The workset the element belongs to
WorksetId worksetId = elem.WorksetId;
message += ("\nWorkset Id : " + worksetId.ToString());
// Model Updates Status of the element
ModelUpdatesStatus updateStatus = WorksharingUtils.GetModelUpdatesStatus(doc, elem.Id);
message += ("\nUpdate status : " + updateStatus.ToString());
// Checkout Status of the element
CheckoutStatus checkoutStatus = WorksharingUtils.GetCheckoutStatus(doc, elem.Id);
message += ("\nCheckout status : " + checkoutStatus.ToString());
// Getting WorksharingTooltipInfo of a given element Id
WorksharingTooltipInfo tooltipInfo = WorksharingUtils.GetWorksharingTooltipInfo(doc, elem.Id);
message += ("\nCreator : " + tooltipInfo.Creator);
message += ("\nCurrent Owner : " + tooltipInfo.Owner);
message += ("\nLast Changed by : " + tooltipInfo.LastChangedBy);
Autodesk.Revit.UI.TaskDialog.Show("GetElementWorksharingInfo", message);
}

Public Sub GetElementWorksharingInfo(doc As Document, elem As Element)
Dim message As [String] = [String].Empty
message += "Element Id: " + elem.Id.ToString
' The workset the element belongs to
Dim worksetId As WorksetId = elem.WorksetId
message += (vbLf & "Workset Id : " + worksetId.ToString())
' Model Updates Status of the element
Dim updateStatus As ModelUpdatesStatus = WorksharingUtils.GetModelUpdatesStatus(doc, elem.Id)
message += (vbLf & "Update status : " + updateStatus.ToString())
' Checkout Status of the element
Dim checkoutStatus As CheckoutStatus = WorksharingUtils.GetCheckoutStatus(doc, elem.Id)
message += (vbLf & "Checkout status : " + checkoutStatus.ToString())
' Getting WorksharingTooltipInfo of a given element Id
Dim tooltipInfo As WorksharingTooltipInfo = WorksharingUtils.GetWorksharingTooltipInfo(doc, elem.Id)
message += (vbLf & "Creator : " + tooltipInfo.Creator)
message += (vbLf & "Current Owner : " + tooltipInfo.Owner)
message += (vbLf & "Last Changed by : " + tooltipInfo.LastChangedBy)
Autodesk.Revit.UI.TaskDialog.Show("GetElementWorksharingInfo", message)
End Sub
Inheritance Hierarchy
Autodesk.Revit.DB WorksharingUtils