Origin Property


The top left corner of the color fill legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic
Public Property Origin As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ Origin {
	XYZ^ get ();
	void set (XYZ^ value);
}

Remarks

The origin point must be on the view plane this legend is placed on.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The origin is not on the view plane that this legend is placed on.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also