Enables the "Do not show again" for a task dialog.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- dialogId
- Type: System String
The non localized dialog identifier. It is used to store in Revit.ini the choice the user made the last time the dialog was shown.
- enableDoNotShow
- Type: System Boolean
The boolean to enable or disable the do not show me again functionality.
- doNotShowText
- Type: System String
The customized localized string that shows along with the do not show again checkbox.
Remarks
Thrown if the TaskDialog also has VerificationText set as the two cannot coincide in the same TaskDialog.
When enabled, the TaskDialog will contain a checkbox with the text specified to not show the task dialog again.
By default a task dialog will not have this check box.
If the user checks the check box, the next call to Show() for the indicated dialog id returns the choice the user made the last time the dialog was shown.