AddLine Method


Inserts a IndexLine segment into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017

Syntax

C#
public void AddLine(
	IndexLine line
)
Visual Basic
Public Sub AddLine ( _
	line As IndexLine _
)
Visual C++
public:
void AddLine(
	IndexLine^ line
)

Parameters

line
Type: Autodesk.Revit.DB.DirectContext3D IndexLine
The line segment to be inserted.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null
Autodesk.Revit.Exceptions InvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also