Sets the filter enabled flag.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filterElementId
- Type: Autodesk.Revit.DB ElementId
The ElementId of the filter.
- enable
- Type: System Boolean
True if the specified filter should be enabled in this view, false otherwise.
Remarks
Several filters can be applied to a view in a sertain order. This enable/disable flag allows one to quickly turn on/off the action of a particular filter in this view (without removing the filter from the set of applied filters and loosing the corresponding overrides). By default, all the filters applied to a view are enabled.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |