Replace a shared family parameter with a new non-shared family parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- currentParameter
- Type: Autodesk.Revit.DB FamilyParameter
The current family parameter.
- parameterName
- Type: System String
The name of the new family parameter.
- groupTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
The identifier of the group to which the new family parameter belongs.
- isInstance
- Type: System Boolean
Indicates if the new parameter is instance or type.
Return Value
If replacement was successful the new family parameter is returned, otherwise an exception with failure information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument-"currentParameter" or "parameterName"-is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the input argument-"currentParameter"-is invalid, or the input parameter group cannot be assigned to the new parameter, or the input name string contains illegal characters, or duplicated with existing parameter name. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when trying to replace a built-in parameter or family parameter. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error. Or trying to replace with an instance parameter of image type. |