Add a new locked alignment into the Autodesk Revit document.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view that determines the orientation of the alignment.
- reference1
- Type: Autodesk.Revit.DB Reference
The first reference.
- reference2
- Type: Autodesk.Revit.DB Reference
The second reference.
Return Value
If creation was successful the new locked alignment dimension is returned, otherwise an exception with failure information will be thrown.Remarks
These two references must be one of the following combinations:
- 2 planar faces
- planar face and reference plane
- 2 lines
- line and point
- line and reference plane
- 2 arcs
- 2 cylindrical faces
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument-"view" or "headerReference" or "otherReference"-is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the input argument-"headerReference" or "otherReference"-is invalid. |