An object that specifies the type of a floor in Autodesk Revit.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
The structural layers of the floor can be accessed via this object.
Examples

public void GetInfo_FloorType(FloorType floorType)
{
string message;
// Get whether FloorType is a foundation slab
message = "If is foundation slab : " + floorType.IsFoundationSlab;
TaskDialog.Show("Revit",message);
}

Public Sub GetInfo_FloorType(floorType As FloorType)
Dim message As String
' Get whether FloorType is a foundation slab
message = "If is foundation slab : " & Convert.ToString(floorType.IsFoundationSlab)
TaskDialog.Show("Revit", message)
End Sub
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB ElementType
Autodesk.Revit.DB HostObjAttributes
Autodesk.Revit.DB FloorType
Autodesk.Revit.DB Element
Autodesk.Revit.DB ElementType
Autodesk.Revit.DB HostObjAttributes
Autodesk.Revit.DB FloorType