Returns a normal vector at the given index
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- idx
- Type: System Int32
A zero-based index
Return Value
XYZ value representing a normal vectorExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value is not a valid index of a normal of the polymesh. A valid valure is not negative and is smaller than the number of normals in the polymesh. |