ShadeDepth Property


How far any auto-generated shades should extend from the wall surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public double ShadeDepth { get; set; }
Visual Basic
Public Property ShadeDepth As Double
	Get
	Set
Visual C++
public:
property double ShadeDepth {
	double get ();
	void set (double value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: The shade depth is less than zero.

See Also