StirrupTieAttachmentType Property


Identifies the StirrupTieAttachmentType of the current Rebar element. The RebarStyle of the Rebar element must be StirrupTie.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public StirrupTieAttachmentType StirrupTieAttachmentType { get; set; }
Visual Basic
Public Property StirrupTieAttachmentType As StirrupTieAttachmentType
	Get
	Set
Visual C++
public:
property StirrupTieAttachmentType StirrupTieAttachmentType {
	StirrupTieAttachmentType get ();
	void set (StirrupTieAttachmentType value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions DisabledDisciplineException When setting this property: None of the following disciplines is enabled: Structural.

See Also