AddReferencePlane Method (Plane)


Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public void AddReferencePlane(
	Plane refPlane
)
Visual Basic
Public Sub AddReferencePlane ( _
	refPlane As Plane _
)
Visual C++
public:
void AddReferencePlane(
	Plane^ refPlane
)

Parameters

refPlane
Type: Autodesk.Revit.DB Plane
The geometry of the new reference plane.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also