Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- part
- Type: Autodesk.Revit.DB Part
The part to be tested
Return Value
The length of the longest chain.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |