Retrieves the GUID representing the subelement in DWF and IFC export.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- subelement
- Type: Autodesk.Revit.DB Subelement
The subelement.
Return Value
The value of the GUID representing the subelement in the export context.Remarks
This id is used in the contents of DWF export and IFC export and it should be used only when cross-referencing to the contents of these export formats. When storing Ids that will need to be mapped back to subelements in future sessions, UniqueId must be used.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |