HostElementId Property


The host element ID for the load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2015

Syntax

C#
public ElementId HostElementId { get; }
Visual Basic
Public ReadOnly Property HostElementId As ElementId
	Get
Visual C++
public:
property ElementId^ HostElementId {
	ElementId^ get ();
}

Remarks

If the load is hosted this is the id of the Analytical Element that hosts the load. If the load is not hosted, InvalidElementId is returned.

See Also