This method is called after unhandled curve was tessellated to polyline segments and sent to the output.
Note for 2D export: if the export is performed for the view in non-Wireframe display style, then
- this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
- this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- segments
- Type: Autodesk.Revit.DB PolylineSegments
A structure describing the polyline segments.