This method is called when a Face edge is being output.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- node
- Type: Autodesk.Revit.DB FaceEdgeNode
An output node that represents a Face edge.
Return Value
Return RenderNodeAction.Proceed if you wish to receive tessellated geometry (line or polyline segments) for this face edge, or otherwise return RenderNodeAction.Skip.Note: if the export is performed for the view in non-Wireframe display style tesselated geometry will be output regardless of the return value.
Remarks
Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.
Note: if the export is performed for the view in non-Wireframe display style this method will be called regardless of whether the object will be eventially output, i.e. even if it's occluded by another element.