ConceptualConstructionId Property


The id of the conceptual construction associated with the reference surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012

Syntax

C#
public ElementId ConceptualConstructionId { get; set; }
Visual Basic
Public Property ConceptualConstructionId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ ConceptualConstructionId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The input element conceptualConstructionId is not a valid ConceptualConstructionType element id.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also