Exports a gbXML file from a mass model document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folder
- Type: System String
Indicates the path of a folder where to export the gbXML file.
- name
- Type: System String
Indicates the name of the gbXML file to export. If it doesn't end with ".xml", extension ".xml" will be added automatically. The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
- options
- Type: Autodesk.Revit.DB.Analysis MassGBXMLExportOptions
Options which control the contents of the export.
Remarks
This is only available for projects containing one or more instances of Conceptual Mass families.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The path is not valid for exporting gbXML files. -or- The name is empty or not valid for exporting gbXML files. -or- options object is invalid: There should be at least one Id in MassZoneIds, the MassIds should be for masses without mass floors. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | Exporting is not allowed in the current application mode. -or- The weather station name is not valid for exporting gbXML files. -or- Cannot export gbXML files, because the energy model setting is off. -or- Failed to export gbxml files due to internal errors. |