GetValidCategoriesForSchedule Method


Gets a list of categories that can be used for a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetValidCategoriesForSchedule()
Visual Basic
Public Shared Function GetValidCategoriesForSchedule As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidCategoriesForSchedule()

Return Value

The IDs of all valid categories.

See Also