GroundPlaneLevelId Property


Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011

Syntax

C#
public ElementId GroundPlaneLevelId { get; set; }
Visual Basic
Public Property GroundPlaneLevelId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ GroundPlaneLevelId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: the element level is not a valid Ground Plane Level element.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also