GetSupportedParameterIds Method


Retrieves collection of all parameters supported by the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public IList<ElementId> GetSupportedParameterIds()
Visual Basic
Public Function GetSupportedParameterIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetSupportedParameterIds()

Remarks

Supported parameters depends on CategoryId property.

See Also