GetExcludedCategoryIds Method


Returns ElementIds for Category elements which are excluded (not taken into account) by route calculation. These categories are always excluded, regardless of the EnableIgnoredCategoryIds value. If an excluded category has sub-categories, then the sub-categories will be excluded as well.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020

Syntax

C#
public ICollection<ElementId> GetExcludedCategoryIds()
Visual Basic
Public Function GetExcludedCategoryIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetExcludedCategoryIds()

Return Value

The ids of Categories which are excluded by route calculation.

See Also