RebarStyle Property


Identifies the RebarStyle of the current Rebar element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public RebarStyle RebarStyle { get; set; }
Visual Basic
Public Property RebarStyle As RebarStyle
	Get
	Set
Visual C++
public:
property RebarStyle RebarStyle {
	RebarStyle get ();
	void set (RebarStyle value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions DisabledDisciplineException When setting this property: None of the following disciplines is enabled: Structural.

See Also