This method creates a constraint for a given Rebar Constrained Handle Tag. Will throw exception if used for Shape Driven Rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- handle
- Type: Autodesk.Revit.DB.Structure RebarConstrainedHandle
The handle of the rebar that will be constrained.
- targetReferences
- Type: System.Collections.Generic IList Reference
The references to which the rebar handle will be constrained. This collection must contain one or more references to faces of elements that can host rebar.
- isConstraintToCover
- Type: System Boolean
If true the RebarConstraintType will be set to ToCover, otherwise RebarConstraintType will be set to FixedDistanceToHostFace.
- offsetValue
- Type: System Double
The distance from references to the rebar handle.
Return Value
Returns the newly created RebarConstraint.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Constrained rebar is a shape driven rebar element. -or- handle is no longer valid. -or- targetReferences is empty. -or- targetReferences do not represent faces from structurals that can host rebar. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |