Returns the id of the first workset to pass the filter(s).
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The first workset id.Remarks
This will reset the collector to the beginning and find the first workset that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter. |