UniqueID Property


This method will return the fabrication id. This represents the link between the Revit and the Steel Core element.

Namespace: Autodesk.Revit.DB.Steel
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019

Syntax

C#
public Guid UniqueID { get; internal set; }
Visual Basic
Public Property UniqueID As Guid
	Get
	Friend Set
Visual C++
public:
property Guid UniqueID {
	Guid get ();
	internal: void set (Guid value);
}

Remarks

This id should not be confused with the guid returned by ExportUtils.GetExportId().

See Also