Adds the two specified vectors and returns the result.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- left
-
Type:
Autodesk.Revit.DB
XYZ
The first vector.
- right
-
Type:
Autodesk.Revit.DB
XYZ
The second vector.
Return Value
The vector equal to the sum of the two source vectors.Remarks
The added vector is obtained by adding each coordinate of the right vector
to the corresponding coordinate of the left vector.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when left or right is a null reference ( Nothing in Visual Basic) . |