Name Property


The name associated with the reference object. The name does not need to be unique. The name must not be empty and must contain valid characters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
	Get
	Set
Visual C++
public:
property String^ Name {
	String^ get ();
	void set (String^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: value cannot be used as a name for the direct shape reference.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also