Gets ForgeDM folder id where the model locates.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- forceRefresh
- Type: System Boolean
Cached value will be refreshed by sending a service call when forceRefresh is true.
Remarks
It is empty for non-cloud model; It is cached in Revit model opened session after getting it if forceRefresh is false; ForgeDM folder id can be changed during Revit model opened session, set forceRefresh as 'true' to get new value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions RevitServerUnauthorizedException | Thrown when cannot get data from ForgeDM for Revit cloud model. |