BottomLevelId Property


The bottom level id of the area based load boundary line.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023

Syntax

C#
public ElementId BottomLevelId { get; set; }
Visual Basic
Public Property BottomLevelId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ BottomLevelId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Remarks

The bottom level's elevation cannot be higher than the top level.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The ElementId levelId cannot be used as the bottom level. The ElementId levelId is not a Level or it's elevation is higher than the top level's elevation.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also