Interval Property


The interval between labels to be created in the set, in Revit internal model units (standard Imperial feet). The default value is null. When null, a predefined interval value will be used, depending on the unit setting for stationing units in the document. For standard imperial, the default is 100 ft. For survey imperial, the default is 100 USft (US survey). For metric, the default is 1000 m.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021.1

Syntax

C#
public Nullable<double> Interval { get; set; }
Visual Basic
Public Property Interval As Nullable(Of Double)
	Get
	Set
Visual C++
public:
property Nullable<double> Interval {
	Nullable<double> get ();
	void set (Nullable<double> value);
}

See Also