DocumentReloadingLatest Event


Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021

Syntax

C#
public event EventHandler<DocumentReloadingLatestEventArgs> DocumentReloadingLatest
Visual Basic
Public Event DocumentReloadingLatest As EventHandler(Of DocumentReloadingLatestEventArgs)
Visual C++
public:
 event EventHandler<DocumentReloadingLatestEventArgs^>^ DocumentReloadingLatest {
	void add (EventHandler<DocumentReloadingLatestEventArgs^>^ value);
	void remove (EventHandler<DocumentReloadingLatestEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to reload latest changes from a central model.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentReloadingLatest event will be raised immediately after latest changes reloading from a central model is finished.

See Also