IsValidHostId Method


Indicates if the provided host id can host line loads The document containing both the host and the load The id of the analytical panel that is about to host a line load True if a line load can be placed on the input host id

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023

Syntax

C#
public static bool IsValidHostId(
	Document pDoc,
	ElementId hostId
)
Visual Basic
Public Shared Function IsValidHostId ( _
	pDoc As Document, _
	hostId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidHostId(
	Document^ pDoc, 
	ElementId^ hostId
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also