Sets the name of the Schema.
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- schemaName
- Type: System String
The name for the Schema.
Return Value
The SchemaBuilder object may be used to add more settings.Remarks
The name is a user-friendly identifier of the Schema. GUIDs are used exclusively for Schema identity, but the name is useful to identify the Schema during development or in an error message. This field is required.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The parameter schemaName is not acceptable for naming Extensible Storage objects. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The SchemaBuilder has already finished building the Schema. |