SetValues Method


Sets the value set to the demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011

Syntax

C#
public void SetValues(
	ICollection<ElectricalDemandFactorValue> values
)
Visual Basic
Public Sub SetValues ( _
	values As ICollection(Of ElectricalDemandFactorValue) _
)
Visual C++
public:
void SetValues(
	ICollection<ElectricalDemandFactorValue^>^ values
)

Parameters

values
Type: System.Collections.Generic ICollection ElectricalDemandFactorValue

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also